loading

enable passwordコマンドの使い方や実行例 (Ciscoコマンド)

ITインフラに特化した
ハイスキルのエンジニアが集まる会社

  1. enable password

enable password (イネーブル パスワード)

enable password(Ciscoコマンド)の使い方や実行例、読み方などを解説します。シスコプレミアパートナーのネプラス(株)が提供するCiscoコマンド資料です。

enable password コマンドとは?

enable password (読み方:イネーブル パスワード)

イネーブルパスワードを設定する

特権モードへ移動する際のパスワードを設定する。

enable passwordの実行例

Router>en
Router#
Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#
Router(config)#enable password free4ng1n4
Router(config)#
Router(config)#
Router(config)#exit
Router#exit
Router>
Router>en
Password:free4ng1n4
Router#

enable passwordのポイント解説!
enable passwordのポイント解説!

デフォルトではパスワードが設定されていないため、enableと打つだけで特権モードへ移動できるが、セキュリティ上、イネーブルパスワードを設定しておくのが基本。
大文字と小文字は区別される。パスワードは数字、大文字、小文字を組み合わせ、辞書攻撃などを防ぐのが基本。

※この資料はCiscoコマンド学習者・エンジニアのために無償公開しているものです。無断転載はご遠慮ください。

Cisco案件も多数あります

ネプラスではITインフラ案件、シスコ案件を多数取り扱い。
ネプラスへの転職・ご就業を希望されるエンジニアの方はこちらよりエントリーください。

エントリーはこちらから↓
エントリーはこちら↓

インフラ業界に特化したプロフェッショナル
が集まるネプラスで働きませんか?

直近半年間のリファラル中途採用率は4割超
SESからの転職者8割定着率は94%と高い社員満足度を誇っています。

Job Opportunities
募集職種

  • ネットワークエンジニア

    大手SIer直請け案件に参画。ネットワークの提案、設計、構築などをお任せします。

    募集要項を見る
  • クラウドエンジニア

    ■AWS,Azure等■クラウドの提案、設計、構築などをお任せします。

    募集要項を見る

簡単45秒!エントリーはこちら

弊社にご興味がある方はお気軽にエントリー下さい!

エントリーフォームへ

ネプラスのスキルアップ支援制度

ネプラスでは、創業以来エンジニアの方のスキルアップ支援に力をいれています。
インフラエンジニアのさらなるスキルアップを目指す研修や就業後には学習用機器の無償貸出や購入支援も行っております。また一部、資格試験代の支給や試験合格時の手当なども充実しています。ネプラス(株)に興味を持たれた方はぜひお気軽にエントリーください。

  • スキルアップ支援 機材の無償貸出 機材の無償貸出
  • スキルアップ支援 資格試験代の支給 資格試験代の支給
  • スキルアップ支援 スキルアップ研修 スキルアップ研修

Cisco・ネットワーク機器の販売ならアイティープロダクト

学習用に最適な小型の中古機器~大規模ネットワークに対応する大型機器まで幅広く取り扱い。
運営会社のネプラス(株)はシスコシステムズのプレミアパートナーです。

Ciscoコマンド一覧

Ciscoルータコマンドが確認できます。掲載されているコマンド一覧は下記をご確認ください。

enable 特権モードへ移動する
enable password イネーブルパスワードを設定する
enable secret イネーブルパスワードを暗号化する
show running-config コンフィグを表示
copy running-config startup-config 現在の設定を保存する
show ip route ルーティングテーブルを表示
show clock 時刻を表示
show version ルータのいろいろな情報を表示
show logging ルータが認識したイベントを表示
show arp ARP cache(アープキャッシュ)の表示
dir flash flashメモリ情報を表示
show environment ルータの置かれた環境を表示
show processes cpu 各プロセスのcpu使用率を表示
show processes memory 各プロセスのメモリを表示
show tech support ルータのシステム情報を表示
show diagnostic status モジュール情報を表示
show cdp neighbors CDPを利用して隣接ルータの情報を確認
show interface インターフェイスの状態を表示
show ip interface brief インターフェイスの状態をシンプルに表示
no shutdown インターフェイスを立ち上げる
configure terminal グローバルコンフィグレーションモードへ移動する
terminal length 0 表示する行の長さを決定する
line vty 0 4+password~ line vtyにパスワードを設定する
logging x.x.x.x ログサーバを指定
logging buffered 512000 debugging ログをバッファに入れるようにする
ping x.x.x.x x.x.x.x宛ての疎通確認をする
拡張ping 疎通確認をする
traceroute x.x.x.x 通信経路の確認
reload ルータを再起動する
clock timezone JST 9 タイムゾーンを日本時間にする
ip nat inside source static 静的NATの設定
ip nat inside source list 1 pool ~ 動的NATの設定
access-list ~ deny x.x.x.x. アクセスリストを定義する
ip access-group ~ in アクセスリストをインターフェイスに適用する
router rip リップを設定する
version 2 リップバージョン2を設定する
router eigrp [1~65535] EIGRPを設定する
no auto-summary 自動集約を無効にする
passive-interface ~ インターフェイスをパッシブにする
router ospf [1~65535] OSPFを設定する
log-adjacency-changes OSPFルータの隣接関係のログが出るようにする
redistribute ~ 再配信の設定
encapsulation frame-relay インターフェイスをフレームリレーでカプセルする
clear ip route * ルーティングテーブルをクリア
no cdp run CDPを無効にする
encapsulation ppp インターフェイスをpppでカプセル化する
ppp authentication chap pppで暗号化の認証をさせる
banner motd バナーの設定
speed 10または100または1000またはauto インターフェイスの速度を変更する
duplex[fullまたはhalfまたはauto] インターフェイスのduplexを変更する
aaa new-model 認証機能を設定する
no ip domain-lookup ドメイン名からの名前解決サービスを止める
isdn switch-type ntt スイッチタイプをnttに設定する
ntp server x.x.x.x NTPサーバのアドレスを指定する
service compress-config コンフィグを圧縮する
ip tcp header-compression TCPヘッダー圧縮をする
clock set ~ 日時を設定する
copy flash tftp flashメモリからtftpサーバへコピーする
copy tftp flash tftpサーバからflashメモリへコピーする